Ford Mustang Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter · #1 ·
I'm looking to replace the TPS on my car,. When the Megasquirt system was installed years ago they cut the ground wire from the connecter and grounded it to the throttle body. I know I've read several times in many a thread not to buy cheap/aftermarket parts, so my question; does this hold true for the Throttle Position sensor as well? I see I can by a premium aftermarket sensor for around $50-$60 but a Ford Motorcraft sensor is more like $150. o_O

What are everyone's thoughts on buying an aftermarket TPS?
 

·
Registered
Joined
·
264 Posts
Side note, and im sure you know this, but that tps sensor ground should only be grounded to the “sensor ground” output from the megasquirt. You should make sure to re-wire it correct when you put the new tps sensor in.
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #4 ·
Side note, and im sure you know this, but that tps sensor ground should only be grounded to the “sensor ground” output from the megasquirt. You should make sure to re-wire it correct when you put the new tps sensor in.
Thanks, I pulled the old MS1 system out and went with Pro-M. I want to replace the TPS so the ground is properly connected to the new wiring harness as it should be.
 

·
Registered
Joined
·
3,824 Posts
Thanks, I pulled the old MS1 system out and went with Pro-M. I want to replace the TPS so the ground is properly connected to the new wiring harness as it should be.
I have a new in box NOS Fox TPS that I'll sell you.
 

·
Registered
Joined
·
23 Posts
Stick with Motorcraft, should be able to find one for less than $150 though- check Rock Auto or Tousley Ford. The TPS that came on my BBK TB gave me all kinds of hanging/surging idle issues after about a year, replaced it with Motorcraft and all problems went away. Dad also had a Professional Products EFI system on his '51 F1, and the TPS that came with it we couldn't get within range on the tune program and wouldn't idle for squat. Replaced with Motorcraft and no more issues....
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #8 ·
I already ordered the aftermarket one. We'll see how it goes, I'm not out much if it doesn't work, other than the time to wait for a Motorcraft one to be ordered and shipped.
 

·
Registered
Joined
·
3,824 Posts
Stick with Motorcraft, should be able to find one for less than $150 though- check Rock Auto or Tousley Ford. The TPS that came on my BBK TB gave me all kinds of hanging/surging idle issues after about a year, replaced it with Motorcraft and all problems went away. Dad also had a Professional Products EFI system on his '51 F1, and the TPS that came with it we couldn't get within range on the tune program and wouldn't idle for squat. Replaced with Motorcraft and no more issues....
I too had issues with off brand TPS units and stick with Motorcraft now.
 

·
Registered
Joined
·
3,824 Posts
I already ordered the aftermarket one. We'll see how it goes, I'm not out much if it doesn't work, other than the time to wait for a Motorcraft one to be ordered and shipped.
I could have had a Motorcraft at your door in 2 days. It's all good. Hopefully it works out for you.
 

·
Registered
Joined
·
3,824 Posts

·
Registered
Joined
·
217 Posts
The last Motorcraft one I bought about 6-8 months ago wouldn't consistently return to the same voltage at closed throttle.
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #15 ·
The last Motorcraft one I bought about 6-8 months ago wouldn't consistently return to the same voltage at closed throttle.
I ended up buying a Motorcraft TPS through one of the local dealerships. They only charged me about $55 after taxes. The aftermarket one I purchased, was reading something like 1.2 at closed throttle and the Motorcraft one was reading .92-.93. Not to mention the aftermarket one was open on the top so I really didn't want to use it. I figured that would just be another reason for it to fail prematurely.

1075027
 

·
Registered
Joined
·
346 Posts
I ended up buying a Motorcraft TPS through one of the local dealerships. They only charged me about $55 after taxes. The aftermarket one I purchased, was reading something like 1.2 at closed throttle and the Motorcraft one was reading .92-.93. Not to mention the aftermarket one was open on the top so I really didn't want to use it. I figured that would just be another reason for it to fail prematurely.

View attachment 1075027
I have seen that on a friend's car. Closed all the way... and I mean throttle stop screwed all the way in too, an aftermarket TPS couldn't get below 1.2. Motorcraft was good.
 

·
Registered
Joined
·
374 Posts
I have had bad luck with aftermarket sensors, IACs etc. I stick Motorcraft whenever possible. They seem to be much more likely to work right.
 
1 - 18 of 18 Posts
Top