Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just purchased a 93 lightning 5.8L 2 days ago. The night i bought it, i drove it home for 350miles worked fine no problems. The next morning went on another good trip 200 miles everything worked fine. Last night it had been raining in the evening, i go to start the truck and it fires right up, after i let it warm up, i take off and about 4 miles down the road the truck sputters and backfires a little as i try and give it gas. Eventually just dies. (Rear tank was empty and front tank had 3/4 tank). Try to start-no go...go outside walk near the tailpipe and it smells rich. Wait a few minutes..tried to start and it fired right up...as im driving it felt like power loss at low rpm and would keep sputtering. (This whole time is raining). Turned around and parked it overnight. Today after i get back from work i go to start the lightning today and it wont turn on at all ...got plenty of battery, starter cranks, fuel pressure about 45-50. Never did get it to start...i keep reading on other forums that these trucks are notorious for moisture and rainy day starting problems. Im new to these trucks any information helps. Thanks
 

·
Registered
Joined
·
24,255 Posts
you need to test for fuel and spark

fuel pressure just means you have pressure in the fuel line, does not mean you have fuel entering the combustion chamber.

Have someone crank it, and you spray carb cleaner down the intake, NOT ETHER, does it start and run?
 

·
Registered
Joined
·
950 Posts
Does it have an msd box?
They are bad for getting wet or hot malfunctioning... Only to work again later for a while...
 

·
Registered
Joined
·
16,644 Posts
Yep, sounds like either a coil or ignition module going bad. Did it throw a code/CEL?
 
1 - 6 of 6 Posts
Top