Ford Mustang Forums banner

29961 - 29980 of 30034 Posts

·
Registered
Joined
·
4,535 Posts
Wow, We could be BRUDDA’s Don! Lol. 😂

Reinstalled center console With a wire tuck clean up. Not perfect but it’ll due till I pull it all out one day for a fresh carpet.


The faded shifter section got a fresh coat of dye while I had it out.
 

Attachments

·
Registered
Joined
·
4,535 Posts
Offending safety feature item clearly removed!! Tomorrow night it’s back to column install again..... :)
 

Attachments

·
Registered
Joined
·
35,520 Posts
Recharged the A/C on the Corolla. It was working, but only "coolish" temps. It seemed to hold pressure fine. Weirdness - only 1 R134 fitting on the low side of the compressor with a "high" (red) cap on it. I'm thinking it never had a vacuum pulled and never had a gauge set on it. They just put one fitting on and then tried to add freon.

Anyhow, picked up a fitting set.


Pulled a vacuum down to 29" (only took about 10 minutes - a good sign) and left it overnight - still 29" in the morning. Quickly replaced filter/drier (added 1oz PAG), then pulled vacuum for an hour (30") and charged using the gauges as a go by.

Didn't use a scale because I had no weight spec for the bastard system in the car. But I got to 20-25 psig suction, 200 psig discharge and around 40F vent temps (inside of the glass was fogging on a humid morning - daddy happy!). I'm guessing 15-17 ozs was all it took. Little car sat and idled at 1100 rpm for about 50 minutes - never missed a beat, temps sat right on 200-205F.


However, when I went for a ride - I damn near turned the inside of the car into a freezer. I left the temp gauge in place. With more revs and more air moving across the condenser I saw 21F on the temp gauge.... I AM NOT KIDDING. The compressor wasn't cycling off. Didn't get to play with the temp setting as much as I'd like -- I'm guessing the expansion valve control isn't working like it should. And it's an old system with no high/low pressure switch. It will freeze your ass out of the car. 1973. Who'd'a thunk?

For the time being, I'm going to put a switch in the compressor clutch wire - so I can manually cycle from inside the car. Meanwhile looking to see if I can find replacement expansion valve and add a high/low switch. There's a threaded spot for a switch on the filter/drier. I'll have to pull the system down again to add it -- but now that I know what I'm doing with it -- a piece of cake. The other alternative is to spend $300-400 and buy a completely new under-dash unit (that's what's in the car) with a contemporary control system. I think the compressor and evaporator are working fine. 21F temps and all.... Charge must be close - get over full or under full and warm air shows up. This is anything but warm.
 

·
Registered
Joined
·
35,520 Posts
That looks nice Chris! What item is that which you removed?
 

·
Registered
Joined
·
4,535 Posts
21F is incredible. I wish my ‘02 WJ jeep would hit 40F as it’s some stupid dual climate system computer controlled System and I just had it checked for fill level.... grrrr. Love the system and function of the jeep but I’ll never buy another! The hassle I’ve had with it is crazy.

I took out my air bag column and am replacing it with an earlier tilt column Michael. Darned wheel from Momo is on 4 week back order otherwise I’d have it wrapped up and driving tonight. Oh well. I’ll enjoy it more when it finally arrives.
 

·
Registered
Joined
·
35,520 Posts
I'm slow Chris - you probably answered my question and I don't understand it. What is the item with the cable you removed - the airbag?

Yeah, all the newer stuff has electronic/integrated HVAC for the most part. One of the reasons I wanted a base model Mazda3 back in '17 was it had a simple three-dial system. Twist one for fan speed, twist one for temp, twist one for where you want the air to show up. We're killing ourselves with complexity that takes more than it gives. Said the old guy.
 

·
Registered
Joined
·
12,529 Posts
I see temps like that with the geo at times. There’s so much darn glass that it needs all it can give. Expansion valve replaced two years ago. With average vent temps in 30’s, it takes 3/4 on my fan speed to keep up. I have 20% tint on windows but I discovered they sent dyed tint instead of ceramic. My tint is barely visible now, comparable to 50% or so. And I don’t want to remove old and put new. At least not right now. I’ve never put the fancy gauges on it with vacuum and such, just the cheap gauge on the r134 can during the charge up (it has a slow leak).
 

·
Registered
Joined
·
4,535 Posts
Michael no worries I posted so much (& learned so much) over the past few days it’s hard to read it all. That cable was a safety device to prevent the ignition cylinder from turning if the shifter button is pushed Or if the shifter was in any position besides park. They must have added it in 1990 with the air bag. It’s out now.

With the center console out I was able to clean up space a bit behind the radio which was nice as well.

Now just waiting for the wheel. It was a two week delay but now it’s 4 weeks lol. COVID!

It’s funny that when When the old head unit computer for the temp control acted up in another way years ago it blew cold air out driver side and hot air out the pass side while on summer interstate driving with family to Maine! Horrible. It took 7 new head units till we got one that worked right. But one of those 7 could at times freeze you out with 29F air. So yeah I am sure the car could run colder but the stupid computer isn’t letting it.

I too love the simple three dial vacuum controlled air on the Stang!
 
  • Like
Reactions: 93Cobra#2771

·
Registered
Joined
·
4,535 Posts
Yes horn works with new copper contacts.... happy happy happy!
 

Attachments

  • Like
Reactions: 93Cobra#2771

·
Registered
Joined
·
4,535 Posts
I previously had to hack a used gauge dash piece when I found a cheap used one on line years ago. I didn’t realize there was a difference between pre and post 90s. It was hidden under my 93 column cover pieces. But now it’ll be exposed. I’ll try to cover this up to some acceptable level till I buy a new one.....
 

Attachments

·
Registered
Joined
·
4,535 Posts
And new multifunction stalk.... ouch pricey but sure does look nice.
 

Attachments

·
Registered
Joined
·
4,535 Posts
Ok now ignition key piece need fresh paint to match so.....primer first.
 

Attachments

·
Registered
Joined
·
12,529 Posts
Coming along nicely, Chris!

Maiden voyage on the new to us Waverunner today. Put just over three hours on it. Really fun to ride.

Amazing how susceptible it is to wind. Wasn’t expecting that.

Took our two kayaks as well. So we had to on Waverunner and two padding at a time.

The motor is freaky fast. Can’t imagine one with a supercharger and double the horsepower. 160hp is plenty for me.

All took turns driving. It is a bit of a learning curve to get used to how it steers and such.

Why do I keep thing how fun it would be to have the motor in the geo? It is basically a motorcycle engine and it turns 10000 rpm. Imagine towing through the gears with a 10k redline in a geo? It’s triple the geo’s hp. Lol
 
  • Like
Reactions: Leadsled Coupe

·
Registered
Joined
·
4,535 Posts
Coming along nicely, Chris!

Maiden voyage on the new to us Waverunner today. Put just over three hours on it. Really fun to ride.

Amazing how susceptible it is to wind. Wasn’t expecting that.

Took our two kayaks as well. So we had to on Waverunner and two padding at a time.

The motor is freaky fast. Can’t imagine one with a supercharger and double the horsepower. 160hp is plenty for me.

All took turns driving. It is a bit of a learning curve to get used to how it steers and such.

Why do I keep thing how fun it would be to have the motor in the geo? It is basically a motorcycle engine and it turns 10000 rpm. Imagine towing through the gears with a 10k redline in a geo? It’s triple the geo’s hp. Lol
Wave runners are a blast. I can’t imagine one with that power baseline. I rode one of the first back some 15-20 yrs ago before they got FAST. That was enough for me. Now you can get them with Boost? Yikes. 😳
 

·
Registered
Joined
·
12,529 Posts
Wave runners are a blast. I can’t imagine one with that power baseline. I rode one of the first back some 15-20 yrs ago before they got FAST. That was enough for me. Now you can get them with Boost? Yikes. 😳
I was turning 7k at roughly 35mph. Your barely moving at 2000-3000rpm. Maybe 5mph. It has top speed of 55-60, give or take. 35-40 was all I wanted today. It was rough and windy.

It’s basically a motorcycle motor. Super quick revving.

The pull out of the hole is unbelievable. And the one we have is one of the bigger ones out there. Can’t imagine this same motor in a two seater.

The blown ones are crank driven and have 300ish hp.

We’ve got reverse on this one lol.
 
  • Like
Reactions: Leadsled Coupe

·
Registered
Joined
·
4,535 Posts
Nice! Bet it’s a HOOT.
 
  • Like
Reactions: 93Cobra#2771

·
Registered
Joined
·
2,525 Posts
I’d love to get an MM u joint steering shaft done now but I am going to wait as I would also like a newer steering rack with better “feel” and that requires a different end to it from what I’ve read. So engine cross member, a arms, rack and MMU joint shaft may all get done at the same time one day.....
...
Say Chris, was your plan to upgrade to the later 94-04 rack, and the MM steering shaft? There's an MM shaft here for sale now that supposedly has 50 miles on it. It's for the SN95 racks though, won't work for the Fox rack. He's asked $200 for it, the link is below;
 

·
Registered
Joined
·
4,535 Posts
SN95 rack..... that has improved steering response I believe. That’s was the direction I hope to go in as I recall. Thanks Don I’ll message him.

I‘d love to get an ‘03 rack but hear a true ‘03 rack is tough very tough to get.....
 

·
Registered
Joined
·
2,525 Posts
I have an SN95 rack in my 91 LSC, they are a good improvement over the Fox rack. The Fox racks are all very old now and cores rebuilt, often are sloppy or will develop leaks faster than the original unit. So the 94-04 racks are all better choices, even a stock one.

I bought a reman Cardone rack to try, but I'm sure it won't be a 03/04 Cobra part. The price was right on Amazon, about $130 plus a core, so I'll try it.
 
29961 - 29980 of 30034 Posts
Top